Adobe Flash Player 10.3  -  Bug 2928599

Created on Tuesday, July 26, 2011

Login for more options

Title

[Platform_Linux]VDPAU: Youtube videos stop refreshing once they reach the end

Description

Problem Description:
Once a youtube video reaches its end, it will not refresh when rewound.

Steps to Reproduce:
1. Watch a youtube video, I tried http://www.youtube.com/watch?v=Gho30f6Yut0
2. Wait until it ends
3. Click anywhere in the navigation slider to watch part of it again

Actual Result:
Sound plays but the video does not refresh

Expected Result:
Video plays correctly

Any Workarounds:

Test Configuration

I am attaching glxinfo output. I am seeing this on Fedora 15 x86_64, with Firefox 5.0, running gnome shell and 275.21 nvidia drivers. I have enabled vdpau by adding EnableLinuxHWVideoDecode=1 to /etc/adobe/mms.cfg

App Language(s) English
OS Language(s) ALL
Platform(s) Linux
Browser(s) Firefox All

Notes (15)

  • belegdol

    1:31:11 AM GMT+00:00 Jan 24, 2012

    The seeking issue was fixed in 11.2 beta 3 and is still working fine with 11.2 beta 4. I'll open a new bug report wrt. the crashes once I find a reproducible way to trigger them.

  • belegdol

    2:34:51 AM GMT+00:00 Dec 28, 2011

    This is all I got:
    Program received signal SIGABRT, Aborted.
    0x0000003106836285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
    64 return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
    (gdb) bt
    #0 0x0000003106836285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
    #1 0x0000003106837b9b in __GI_abort () at abort.c:91
    #2 0x000000310682ee9e in __assert_fail_base (fmt=<optimized out>, assertion=0x31090b8db8 "req == dpy->xcb->pending_requests",
    file=0x31090b8ccb "xcb_io.c", line=<optimized out>, function=<optimized out>) at assert.c:94
    #3 0x000000310682ef42 in __GI___assert_fail (assertion=0x31090b8db8 "req == dpy->xcb->pending_requests", file=
    0x31090b8ccb "xcb_io.c", line=140, function=0x31090b9060 "dequeue_pending_request") at assert.c:103
    #4 0x00000031090450ee in dequeue_pending_request (dpy=<optimized out>, req=<optimized out>) at xcb_io.c:140
    #5 0x0000003109045e2c in _XReply (dpy=0x7fec49e93000, rep=0x7fff4d400f20, extra=2, discard=1) at xcb_io.c:574
    #6 0x000000310903b127 in XQueryKeymap (dpy=0x7fec49e93000, keys=0x7fff4d400f70 "\220\315\353I\354\177") at QuKeybd.c:46
    #7 0x00007fec40ab8c33 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #8 0x00007fec40ab8e21 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #9 0x00007fec40ab772d in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #10 0x00007fec409b28c1 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #11 0x00007fec409b6b79 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #12 0x00007fec408d38b4 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #13 0x00007fec40902261 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #14 0x00007fec4090278a in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #15 0x00007fec40abccf6 in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #16 0x00007fec40a666db in ?? () from /usr/lib64/flash-plugin/libflashplayer.so
    #17 0x0000003108c4626b in g_timeout_dispatch (source=0x7fec2b2212b0, callback=<optimized out>, user_data=<optimized out>)
    at gmain.c:3891
    #18 0x0000003108c44a7d in g_main_dispatch (context=0x7fec49e4f0c0) at gmain.c:2425
    #19 g_main_context_dispatch (context=0x7fec49e4f0c0) at gmain.c:2995
    #20 0x0000003108c45278 in g_main_context_iterate (context=0x7fec49e4f0c0, block=<optimized out>, dispatch=1, self=<optimized out>)
    at gmain.c:3073
    #21 0x0000003108c4544c in g_main_context_iteration (context=0x7fec49e4f0c0, may_block=1) at gmain.c:3136
    #22 0x00007fec4b5c39ea in base::MessagePumpForUI::RunWithDispatcher (this=0x7fec49e3c0a0, delegate=<optimized out>,
    dispatcher=<optimized out>) at /usr/src/debug/xulrunner-9.0.1/mozilla-release/ipc/chromium/src/base/message_pump_glib.cc:195
    #23 0x00007fec4b5b1b7b in RunHandler (this=0x7fff4d402b78)
    at /usr/src/debug/xulrunner-9.0.1/mozilla-release/ipc/chromium/src/base/message_loop.cc:201
    #24 MessageLoop::Run (this=0x7fff4d402b78)
    at /usr/src/debug/xulrunner-9.0.1/mozilla-release/ipc/chromium/src/base/message_loop.cc:175
    #25 0x00007fec4ac21563 in XRE_InitChildProcess (aArgc=6, aArgv=<optimized out>, aProcess=GeckoProcessType_Plugin)
    at /usr/src/debug/xulrunner-9.0.1/mozilla-release/toolkit/xre/nsEmbedFunctions.cpp:516
    #26 0x0000000000401270 in main (argc=8, argv=<optimized out>)
    at /usr/src/debug/xulrunner-9.0.1/mozilla-release/ipc/app/MozillaRuntimeMain.cpp:81
    (gdb)

  • belegdol

    1:21:43 AM GMT+00:00 Dec 28, 2011

    On the other hand w/ vdpau enabled, 11.2.202.160 is crashing a lot. How do I obtain a useful backtrace?

  • belegdol

    1:12:19 AM GMT+00:00 Dec 28, 2011

    Hmm, I could have sworn I was able to reproduce this issue with 11.2.202.160, but seems that it is working correctly now. Sorry for the noise, I guess. I'll keep an eye on the problem.

  • belegdol

    12:47:38 AM GMT+00:00 Dec 28, 2011

    I have just tried with the latest 295.09 beta driver but it does not help.

  • Qingyan Zhu

    6:09:25 PM GMT+00:00 Dec 27, 2011

    Belegdol, thanks for your quick response. This is probably caused by the GPU driver, could you please update your display card driver?

  • belegdol

    3:29:48 AM GMT+00:00 Dec 27, 2011

    Disabling the hardware acceleration (either using right click → settings or by moving /etc/adobe/mms.cfg) works the problem around, so it is definitely an issue with vdpau, probably specific to GPU/driver.
    I have posted the bug report to nvidia, let's see what they respond:
    http://www.nvnews.net/vbulletin/showthread.php?t=171109

  • Qingyan Zhu

    5:15:49 PM GMT+00:00 Dec 26, 2011

    Thanks for your info, since we cannot reproduce it, please disable your hardware acceleration and test it again.

  • belegdol

    3:22:20 AM GMT+00:00 Dec 25, 2011

    I have just re-tested with Firefox 9.0.1 and Flash Player 11.2.202.160 - the problem is still there.
    I have also made another observation: with both Flash Player 11.1 and 11.2, it is not necessary to wait until the video reaches the end - it is enough to skip forward using the progress bar to prevent the video from refreshing correctly.

  • belegdol

    3:43:32 PM GMT+00:00 Nov 26, 2011

    I would like to add more info about my configuration. The GPU I have is a GeForce GTX 485M, and I am running Fedora 16 x86_64.

  • belegdol

    11:39:48 AM GMT+00:00 Nov 26, 2011

    I just tried with 290.10 nvidia driver and flash player 11.2 beta2 from adobe labs, the issue is still there.

  • Qingyan Zhu

    10:50:15 PM GMT+00:00 Nov 23, 2011

    Close the bug as cannot reproduce currently, feel free to leave notes if the issue is reproducible with latest flash player(http://get.adobe.com/flashplayer/)

  • Qingyan Zhu

    6:32:22 PM GMT+00:00 Nov 7, 2011

    Thanks for reporting to adobe. I'm sorry that you are running into the issue, but the issue failed to reproduce on ubuntu 10.10 i686 + ATI Radeon HD 3450 + flash player 11.0.1.152. Since the issue not reproduced when disabling hardware acceleration, could you please update your display card driver to test it again? Thanks

  • belegdol

    9:59:06 AM GMT+00:00 Oct 9, 2011

    Still reproducible with firefox 7.0.1 and flash player 11.0.1.152.

  • belegdol

    10:35:18 AM GMT+00:00 Jul 26, 2011

    Please note that this issue occurs w/ Flash Player 10.3 and nspluginwrapper as well and can be worked around by disabling hardware video decoding.

Duplicate ID
Reported By belegdol

Status

State Closed
Status Withdrawn
Reason CannotReproduce

Importance

Priority 3-High
Frequency All users will encounter
Failure Type Incorrectly Functioning
Product Area Video

Build

Found In Build 10.3.181.14
Fixed In Build

Attachments (1)

Votes (0)

Your session has expired! Click to login
Current form data will be preserved

Cancel