Adobe Flash Player 10.3  -  Bug 2941616

Created on Friday, August 12, 2011

Login for more options

Title

[Platform_Windows]Sound repeating and building up bug

Description

Problem Description: If you create a clip on the timeline with sound dropped on to frames, but with a stop command at the start and then just around the main timeline, it seems like the stop command is ignored and the sound just plays over and over.

Steps to Reproduce: Create a new .fla file. Drop a movie clip on the the main timeline. Add a stop command on frame 1 of this new clip and a sound on frame 2. In theory you can trigger the sound by using clip.gotoAndPlay(2). This works, but then if you go to another frame on the main timeline and then go back to a previous frame on the main timeline you will experience the problem.

Actual Result: The sound on the clip will play voer and over and build up in to a loud noise.

Expected Result: the sound doesn't play until I tell the clip to gotoAndPlay(2)

Any Workarounds: None.

You can see the bug in action by visiting: http://www.thepodge.co.uk/playfp103bug.html

I've attached the fla file to this report.

Test Configuration

1, For issues related to Video/Audio/Rendering, please upload your system info file.
http://kb2.adobe.com/cps/839/cpsid_83952.html

2, It will be always helpful if you can provide code snippet that can reproduce the issue.

App Language(s) ALL
OS Language(s) ALL
Platform(s) Windows 7
Browser(s) Firefox All

Notes (16)

  • Rapz07.com

    12:31:09 AM GMT+00:00 Oct 8, 2011

    Pearl

  • chris.campbell

    3:23:07 PM GMT+00:00 Aug 25, 2011

    For additional details on the 10.3.183.7 release, please see: http://forums.adobe.com/message/3883979

  • mushr00mer

    8:53:43 AM GMT+00:00 Aug 24, 2011

    We need to know when that release is. Clients are currently accessing broken swf's. Please post an estimated day of delivery! Thanks

  • mushr00mer

    8:42:45 AM GMT+00:00 Aug 24, 2011

    We need to know when that release is. Clients are currently accessing broken swf's. Please post an estimated day of delivery! Thanks

  • Ping Huang

    1:04:06 AM GMT+00:00 Aug 24, 2011

    This issue has been fixed in our internal dev build. Please try the fix on our upcoming release. Thanks for reporting.

  • dudesons

    4:44:18 AM GMT+00:00 Aug 22, 2011

    Is there any progress on this bug??

  • undersiege2009

    7:36:41 AM GMT+00:00 Aug 17, 2011

    I started updating some of our games to fix this and it turned out to be completely unfeasible. The sooner this bug is fixed the better - people are complaining!

  • Qingyan Zhu

    7:55:44 PM GMT+00:00 Aug 16, 2011

    @Conman1994, if your browser is IE9, probably related with IE9 new feature--ActiveX Filtering.
    http://ie.microsoft.com/TESTDRIVE/Browser/ActiveXFiltering/About.html, If cannot resolve your issue, pls log a new bug

  • Conman1994

    3:57:17 PM GMT+00:00 Aug 16, 2011

    i download it and it says it installs fine and i can reopen browser. but it didnt install because it keeps saying to install adobe flash player

  • klesniewicz

    1:14:19 PM GMT+00:00 Aug 16, 2011

    Reports are starting to come in finally. Someone just filed this similar (identical?) bug: id=2943508

  • pdpinch

    10:10:57 AM GMT+00:00 Aug 16, 2011

    Please vote! This bug breaks many games on PBSKids.org which, well, it makes little kids cry. =(

  • klesniewicz

    7:39:42 AM GMT+00:00 Aug 16, 2011

    Sorry, I meant "Some of us stil use Flash as..."

  • klesniewicz

    7:39:00 AM GMT+00:00 Aug 16, 2011

    Please fix this as soon as possible. It is quite awful and there are perfectly legitimate reasons to place sound keyframes within a movie clip. This is a basic feauture/function of Flash since -- what? -- FutureSplash 1.0? Some of use still Flash as an animation & multimedia tool!

  • pdpinch

    7:30:57 AM GMT+00:00 Aug 16, 2011

    Please vote! This bug breaks many games on PBSKids.org which, well, it makes little kids cry. =(

  • stylinandy

    3:40:50 PM GMT+00:00 Aug 15, 2011

    Vote note! The Flash apps my company produces are heavily reliant on movieclip animations with timeline audio. The audio looping will stop when the movieclip containing the audio is removed from it's parent - which is good. However, this is still problematic for movieclips with longer animation sequences.

  • Ping Huang

    7:26:18 AM GMT+00:00 Aug 14, 2011

    Thanks for your reporting. We have an internal bug tracking this issue now. If anyone also run into this issue, pls leave a vote note about how this is impact you. Thanks.

Duplicate ID
Reported By undersiege2009

Status

State Closed
Status Fixed
Reason

Importance

Priority 3-High
Frequency All users will encounter
Failure Type Incorrectly Functioning
Product Area Audio

Build

Found In Build 10.3.183.5
Fixed In Build

Attachments (1)

Votes (13)

  • NorakKhath

    12:32:32 AM GMT+00:00 Jan 27, 2014

    It been 3 years and adobe hasn't fix this, unbelievable.

  • KlrSpz

    1:01:46 PM GMT+00:00 Aug 23, 2011

    This has brought down all of our products, without viable work arounds. As everyone mentioned, reworking assets at this point (we're talking 600+) is impossible.

  • mushr00mer

    10:51:47 AM GMT+00:00 Aug 19, 2011

    hundreds of swf's will need hundreds of hours of reword because the clients who use this product will go crazy with loop upon loop upon loop building up to an unpleasant experience.

    You must fix this or else there is no use for audio being dropped into the timeline. that function is broken!

  • Briche Simon

    7:03:07 AM GMT+00:00 Aug 19, 2011

    I work in a web agency that rely on the flash player for almost all of our websites. Our framework is deeply impacted by this bug. As a result, all of the websites we have currently live are audio broken. Please, fix this bug ASAP, there are dozen of them !

  • drkstr_1

    9:33:26 AM GMT+00:00 Aug 17, 2011

    This bug effects a lot of our customer-facing content across many sites. Updating each effected SWF with a workaround is not a viable option for us. Our content will remain broken until a fix can be made.

  • mpowys

    5:48:14 AM GMT+00:00 Aug 17, 2011

    I am having the same issue with timeline added ausios repeating. This is only an issue since upgrading to flash player 10.3

  • dudesons

    1:33:39 AM GMT+00:00 Aug 17, 2011

    Some sound files embedded in timeline inside movieclips repeats them selves, and make totally chaos when playing swf in browsers. Need a fix asap!

  • funkypear

    4:19:16 PM GMT+00:00 Aug 16, 2011

    This is affecting my games and making them unplayable (without muting the computer). It would be virtually impossible to fix this bug web wide.

  • ncam_kal

    2:46:25 PM GMT+00:00 Aug 16, 2011

    The repeating audio overwhelms the audio we use to provide important instructions for our games. We don't have the tech hours to go back and revise all of them. If this persists, we will lose visitors to our site.

  • stillwellmedia

    1:42:54 PM GMT+00:00 Aug 16, 2011

    This bug affects all flash projects containing audio that my company has produced. Some are deployed and hosted on client sites, not at all easy for us to update.

  • eteam33

    1:14:58 PM GMT+00:00 Aug 16, 2011

    I have a number of Flash-based projects that are affected by this and the error is hurting traffic to client sites.

  • klesniewicz

    7:35:20 AM GMT+00:00 Aug 16, 2011

    We were about to deliver a suite of 16 flash games for PBS.org funded by US Dept of Ed. and they will all need to be reworked to avoid this awful bug. Eveything worked fine in Player 10.3.181.34 (released 6/28) but all are broken now. We used some sounds on the timeline in order to sync up character animation and mouth with his dialog. With current Player, timeline audio is being triggered arbitrarily and endlessly (out of control).

  • pdpinch

    7:28:56 AM GMT+00:00 Aug 16, 2011

    This bug breaks the PBSKids Flash game "Dogs on Ice" at http://pbskids.org/martha/games/dogsonice/index.html

Your session has expired! Click to login
Current form data will be preserved

Cancel