Adobe Flash Player 10.3  -  Bug 2941694

Created on Friday, August 12, 2011

Login for more options

Title

[Platform_Mac]Textfields are displaying text vertically in 10.3.183.5 release

Description

Problem Description:
Textfields display text vertically regardless of the width of a textfield.

Steps to Reproduce:
Some code was posted to a discussion http://forums.adobe.com/thread/889711?tstart=0
I have reproduced the bug in Chrome and Firefox on both Mac and Windows after updating to 10.3.183.5

Actual Result:
T
e
x
t

i
s

v
e
r
t
t
i
c
a
l


Expected Result:
Text should be horizontal

Any Workarounds:
Not that I have found
updated by Ping Huang:
the internal bug repro test steps shows this happens only in following test sequence :
1) Instantiate a text field.
2) Before adding text to the text property move the x property to -120;
3) Add text to the text property.
4) Move the textField x property to 50;
5) Add to the stage.
So , the possible workaround you could try is that avoid this sequence or set textfiled's initial x property to positive number.

Updates: This issue is fixed in player version 11.0. if you experience other issues, pls help to report a new bug. Thanks much.

Test Configuration

1, For issues related to Video/Audio/Rendering, please upload your system info file.
http://kb2.adobe.com/cps/839/cpsid_83952.html

2, It will be always helpful if you can provide code snippet that can reproduce the issue.
See this discussion thread http://forums.adobe.com/thread/889711?tstart=0

App Language(s) ALL
OS Language(s) English
Platform(s) Mac 10.6 for Intel
Browser(s) Chrome All

Notes (42)

  • RaulJimenez

    9:50:54 AM GMT+00:00 Oct 7, 2011

    Im experimenting this problem on AIR for Android with Flash CS5.5 when I add the text and my textfield it's out of stage.

  • FUNE78

    6:05:05 AM GMT+00:00 Sep 4, 2011

    Make sure the first word fits into your multiline-textfield and the textfield has 100% width and 100% height, that worked here pretty well.

  • Ping Huang

    2:45:47 AM GMT+00:00 Aug 29, 2011

    @gludion, this bug was closed for its original issue (vertical text, line break). The issue you described could be 2951126, pls check there for updates.

  • gludion

    2:11:26 AM GMT+00:00 Aug 29, 2011

    Why is this issue "Closed" ???
    With 10.3.183.7, the bug is now different: there is no more wordWrap if the textField has multiline=true, autoSize="left", wordWrap=true.

  • luisapew

    12:57:30 AM GMT+00:00 Aug 27, 2011

    * UPDATE *

    Fixed with FP 10.3.183.7. Remember to uninstall Flash Player, before you upgrade to the new player.

  • luisapew

    10:13:18 AM GMT+00:00 Aug 26, 2011

    Hi,

    I had this problem with FP 10.3.183.5 and then I've updated to the latest version 10.3.183.7 and now, instead of a vertical text, my multiline textfield has no wrap and the text is cut!

  • slinky2000

    8:31:48 AM GMT+00:00 Aug 26, 2011

    Why was the decision made to not autoupdate users ont he broken version?

    "Please note that users will not be automatically prompted to download and install this build if they are already at 10.3.183.5. Users below 10.3.183.5 will be prompted at their normal auto update interval"

  • slinky2000

    7:59:30 AM GMT+00:00 Aug 26, 2011

    Hi guys, I can confirm the 10.3.183.7 update has fixed the verticle text issue for me. I don;t see any cutting of text at the moment.

  • Fraggle_Seb

    5:53:23 AM GMT+00:00 Aug 26, 2011

    Hi,

    Can someone at adobe explain the reason for the bug, when / what triggers it and if there is a workaround instead of forcing everyone to update.
    Especially for Chrome users that are mostly stuck with the buggy version.

    Thanks.

  • chris.campbell

    3:20:47 PM GMT+00:00 Aug 25, 2011

    For additional details on the 10.3.183.7 release, please see: http://forums.adobe.com/message/3883979

  • tom_wilson

    7:51:44 AM GMT+00:00 Aug 25, 2011

    I've worked out how to fix this. Read the bug entitled: "How to fix the vertical text bug."
    I created 2 by accident, sorry.

  • Ping Huang

    1:45:52 AM GMT+00:00 Aug 25, 2011

    hi all, now we have a new build for you to download 10.3.183.7 which include a fix for this bug. Please try updating your Flash Player version and confirm the issue is solved. Thank you for all of your feedback. http://www.adobe.com/support/flashplayer/downloads.html

  • martijnkunstman

    10:40:15 AM GMT+00:00 Aug 24, 2011

    Setting the textfield to 'Use device fonts' solves the bug for me for now. Not the most ellegant fix, but better than the bug...

    Haven't found an other workaround jet. Please post your workarounds here....

  • pinki_s_jain

    2:06:42 PM GMT+00:00 Aug 23, 2011

    @Ping Huang
    I added a new bug request for cutting text (# 2949283). Please make sure that when fix is released, wrapping works properly. Otherwise the fix is not going to be totally usable. (also because it wraps texts totally fine with previous releases of flash player). Thank you.

    @EricBanker
    For me it is same kind of thing. Out of three strings I am trying to wrap only one would not wrap and cuts. I added this example to the bug for 11 beta.

  • Ping Huang

    7:43:09 AM GMT+00:00 Aug 23, 2011

    @pinki_s_jain @EricBanker We appreciated if you can file a new bug to report the issue you encountered on FP11 with reproducible test media. This bug is used to tracking original issue (linebreak issue, text change to vertical) . Let's try to maintain single issue for each bug report for people to comment and vote. Thank you.

    @ all, we should be able to update you soon with our release schedule for this issue. Thanks for your patience.













  • EricBanker

    10:50:34 AM GMT+00:00 Aug 22, 2011

    @pinki_s_jain

    I just noticed this in one of our text fields as well. It was one of the fields that was showing vertically before the update to 11 and now it's cutting off the text when it should be wrapping. This seems to only be happening with one text field however and I don't see any reason why this particular one should be doing something differently. It's the same text field as I showed code for before.

  • Ping Huang

    5:42:34 PM GMT+00:00 Aug 21, 2011

    Thanks for all you comments and votes info. This has been processed as top priority and We'll update again once we have a firm date for a hot fix. We appreciate your patience.

    @pinki_s_jain you mentioned the text has been cut when you tried on FP11 beta, pls help us to file a new bug against FP11 beta build. Thank you!

  • pinki_s_jain

    8:26:41 AM GMT+00:00 Aug 19, 2011

    We downloaded FP 11 Beta (11.0.1.98) to see how it would look. It is not wrapping the texfields properly. The text is not shown vertically but where it should start wrapping, it totally cuts the text. This is not acceptable either.

  • krpanocoder

    1:00:45 AM GMT+00:00 Aug 19, 2011

    Hi, here too! please fix it asap!

    Here an user report about that problem:
    http://krpano.com/forum/wbb/index.php?page=Thread&postID=30397#post30397

    And here an example for it:
    http://360emirates.com/panos/textfield_test.php

    I have attached two images:
    bug.jpg - how it look in version 10.3.183.5
    normal.jpg - how it should look (and look in all other FP versions)

  • krpanocoder

    1:00:14 AM GMT+00:00 Aug 19, 2011

    Hi, here too! please fix it asap!

    Here an user report about that problem:
    http://krpano.com/forum/wbb/index.php?page=Thread&postID=30397#post30397

    And here an example for it:
    http://360emirates.com/panos/textfield_test.php

    I have attached two images:
    bug.jpg - how it look in version 10.3.183.5
    normal.jpg - how it should look (and look in all other FP versions)

  • rrivem

    3:48:04 PM GMT+00:00 Aug 18, 2011

    Here's the partial workaround I've found. Thankfully, I handled every textfield within a class (for localization).
    I noticed that the bug appears when the wordWrap is on, so I manually perform the word wrapping.
    You need to call the first function for every textfield with the number of chars per line (sorry, but this was best I could do as fast as possible).


    public static function gmAutoWrapText(aHTML:String, aMaxLength:int):String {
    var vXML:XML = new XML(aHTML);
    gmAutoWrapTextXML(vXML, aMaxLength);
    return vXML.toXMLString();
    }

    private static function gmAutoWrapTextXML(aXML:XML, aMaxLength:int):void {
    for (var i:int = 0; i < aXML.children().length(); i++) {
    var vXML:XML = aXML.children()[i];
    if (vXML.nodeKind() == "text") {
    var vText:String = vXML.toXMLString();
    var vLines:Array = new Array();
    var j:int = 0;
    while (j < vText.length) {
    var vTemp:String = vText.substr(j, aMaxLength);
    if (vTemp.length < aMaxLength) {
    vLines.push(vTemp);
    break;
    }
    var vRegExp:RegExp =/\s\S*$/;
    var vLastSpacePos:int = vTemp.search(vRegExp);
    if (vLastSpacePos <= 0) {
    vLines.push(vTemp);
    j += aMaxLength;
    }
    else {
    vLines.push(vTemp.substr(0, vLastSpacePos));
    j += vLastSpacePos + 1;
    }
    }
    if (vLines.length > 1) {
    delete aXML.children()[i];
    if (i == 0) {
    aXML.prependChild(vLines.join("\n"));
    }
    else{
    aXML.insertChildBefore(aXML.children()[i], vLines.join("\n"));
    }
    }
    }
    else {
    gmAutoWrapTextXML(vXML, aMaxLength);
    }
    }
    }

  • jcurrie331

    2:51:52 PM GMT+00:00 Aug 18, 2011

    Please fix this, the workaround does not work. thx

  • tmy326

    1:45:11 PM GMT+00:00 Aug 18, 2011

    I notice the bug is marked as fixed, is there any timeline when the fixed one will be released. This bug should be definitely marked as P0, and the workaround above does not work.

  • simonaburley

    1:42:55 PM GMT+00:00 Aug 18, 2011

    Please fix this Adobe. we've all spent thousands on Adobe products over the years and have many websites which this bug is affecting. we need a fix asap. Thank you.

  • DenisBulichenko

    10:15:57 AM GMT+00:00 Aug 18, 2011

    Same issue. Please fix it.

  • pinki_s_jain

    7:33:11 AM GMT+00:00 Aug 18, 2011

    We are facing the same issue. We are seeing it on windows or mac, and with IE or firefox. We have not tried on Safari or Chrome. Workarounds listed are not working out for us. It was working fine w previous flash player releases but w 10.3 its broken. Please release fix to 10.3.x version.

  • ppgengler

    9:23:46 AM GMT+00:00 Aug 17, 2011

    I don't have solid repro steps yet, but I have discovered that this bug doesn't always happen with all wrapping text, which may explain why the Adobe folks had some issue reproducing before. As I said I don't have a cononical example, but I have seen it work when wrapping, not work other times, work partially etc. For example I have seen things like

    Here is some text that should
    wrap.

    Here is some text that should
    wrap
    m
    o
    r
    e
    .

    Here is some text that should
    wrap more but now is okay.

    And then eventually it ends up in the one character per line thing. Length definately is a factory, but it doesn't seem to be the only factor affecting things.

    I'm going to keep trying to find workarounds or what the pattern is, but if the Adobe folks have some more insight, information into what exactly the root cause is that might help us figure out a workaround.

    Thanks,
    \Peter

  • zer0spaz

    9:00:13 AM GMT+00:00 Aug 17, 2011

    Affecting my site. We typically have 3,000 uniques a day. This is very frustrating that there hasn't been more responses from Adobe. I can verify that the proposed workaround does not work. Although we have minimal Flash movies, I have been directed to remove all Flash content because of the number of complaints from our clients and public. Sorry you are loosing a customer.

    I do hope Adobe pushes a solution sooner than later for the rest of you.

  • slinky2000

    3:44:40 AM GMT+00:00 Aug 17, 2011

    Another update, this is happening on all browsers, on both Mac and PC running the plugin 10.3.183.5

  • rrivem

    5:48:21 PM GMT+00:00 Aug 16, 2011

    I'm having the same problem in several sites I released. I've tried the workaround (setting x coordinate to positive value before setting the text property) with no success.

    Is there an estimated date for the next release?

  • AbhiBrainNook

    5:16:31 PM GMT+00:00 Aug 16, 2011

    This is also happening to us in our online game BrainNook (www.brainnook.com). Very frustrating because it happens only for people whose Chrome has auto-updated them to this Flash Player version, and there doesn't seem to be an easy way for them to roll back to an earlier version. It makes some screens in the game unreadable -- screens which have been stable and working for months.

    Adobe, please release the fix asap!

  • AbhiBrainNook

    5:14:47 PM GMT+00:00 Aug 16, 2011

    This is also happening to us in our online game BrainNook (www.brainnook.com). Very frustrating because it happens only for people whose Chrome has auto-updated them to this Flash Player version, and there doesn't seem to be an easy way for them to roll back to an earlier version. It makes some screens in the game unreadable -- screens which have been stable and working for months.

    Adobe, please release the fix asap!

  • slinky2000

    11:22:06 AM GMT+00:00 Aug 16, 2011

    More info:

    -> Mine is happening only in my as2 applications when placed inside an old f8 scrollPane.
    -> All my x/y values are positive of textfields and movieclips.

    I presume the scroll PAne is doing something funny.

  • slinky2000

    10:58:19 AM GMT+00:00 Aug 16, 2011

    This is also affecting me in an old product thats still uses f8.

    It only affects me when I do not embed fonts and turn wordWrap to true.

    I cannot get the work around to work

    @MYSjsullivan what do you mean you workaround to the parent clips of the textfield also??

  • EricBanker

    11:42:13 AM GMT+00:00 Aug 15, 2011

    @MYSjsullivan

    Thanks for the info. I'll check the to see if that is the case for us as well. I can't verify at this time.

  • MYSjsullivan

    11:10:12 AM GMT+00:00 Aug 15, 2011

    @Ping Huang
    I was able to get the workaround, thank you very much for the help.

    @EricBanker
    I had to apply the workaround to the parent clips of the textfield also, not sure if that helps you.

  • EricBanker

    8:21:52 AM GMT+00:00 Aug 15, 2011

    I'm having this issue as well but the workaround is not working for me. The text fields I have that are having the issue are instantiated like so:

    var msgText = this.createTextField("msgText", this.getNextHighestDepth(), 8, 0, 284, 65);
    msgText.multiline = true;
    msgText.wordWrap = true;
    msgText.htmlText = "";
    msgText.html = true;
    msgText.autoSize = true;

    Later on the text is added to it and it's width is adjusted

    msgText.htmlText = newMsg;
    msgText.setTextFormat(msgFormat);
    msgText._width = (newWidth - 16);

    But the x and y coordinates are never negative. I have found no way to work around this one.

  • Ping Huang

    6:42:03 AM GMT+00:00 Aug 15, 2011

    @MYSjsullivan
    1, this will be in our next upcoming release.
    2, the repro test steps shows this happens only in following test sequence :
    1) Instantiate a text field.
    2) Before adding text to the text property move the x property to -120;
    3) Add text to the text property.
    4) Move the textField x property to 50;
    5) Add to the stage.
    So , the possible workaround you could try is that avoid this sequence or set textfiled's initial x property to positive number.

  • MYSjsullivan

    6:05:32 AM GMT+00:00 Aug 15, 2011

    Are there any current workarounds?

  • MYSjsullivan

    5:53:55 AM GMT+00:00 Aug 15, 2011

    Will this fix be released in the next Flash Player 10 update?

  • Ping Huang

    9:16:54 AM GMT+00:00 Aug 14, 2011

    Hello, Thanks for your reporting this issue. This has been fixed in our internal development build, and you should be able to verify this fix on our latest FP11 beta. http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11/

  • ianmcdaniel

    9:51:14 AM GMT+00:00 Aug 12, 2011

    See uploaded screenshot to see the results of the bug on my companies large flash app.

Duplicate ID
Reported By ianmcdaniel

Status

State Closed
Status Fixed
Reason

Importance

Priority 3-High
Frequency All users will encounter
Failure Type Incorrectly Functioning
Product Area Text

Build

Found In Build 10.3.183.5
Fixed In Build

Votes (19)

  • martijnkunstman

    1:16:12 AM GMT+00:00 Aug 25, 2011

    affects many of my sites! please fix!

  • tsammons

    6:29:05 AM GMT+00:00 Aug 23, 2011

    We are about to release two prominent and highly visible internal business applications and this bug renders them virtually unusable.

    Additionally, we have three existing intranet apps (HR, Security Clearance, and Help Desk Exchange Email Ticket Processing) that are in production that will be impacted severely.

    An immediate minor version release is critical to correct this issue, as the 10.3.183.5 release contained critical vulnerability fixes and cannot (will not) be rolled back.

    I don't see how you can justify the negative PR and business losses against the urgency that is patently obvious to everyone.

  • random(1)

    3:48:52 AM GMT+00:00 Aug 23, 2011

    I just ran into this a few days ago. I wasted about about an hour coming up with a workaround.

  • dhelfgott

    4:23:15 PM GMT+00:00 Aug 19, 2011

    This bug is negatively affecting our business. It shows up in a key part of our Flash based RIA application. We have thousands of paying customers that have begun calling and complaining to us.

    Please, please DO NOT wait for Flash 11 to release a fix. Please fix it in version 10 ASAP.

    Don Helfgott
    CEO - Inspiration Software, Inc.

  • jcurrie331

    2:47:13 PM GMT+00:00 Aug 18, 2011

    This is not fixed, though labeled Fixed.

  • simonaburley

    1:55:26 PM GMT+00:00 Aug 18, 2011

    It's ruined many of my websites (I'm a webdesigner) which have been running fine for a long time. It has also ruined a new project on the day of it's launch! This bug could potentially cost me thousands of pounds. It needs to be fixed.

  • J J Joven

    1:28:28 PM GMT+00:00 Aug 18, 2011

    Same problem... please fix it!

  • pinki_s_jain

    7:34:16 AM GMT+00:00 Aug 18, 2011

    please release fix for 10.3.183.5 version. This issue is causing big issues for our app. We downloaded FP 11 Beta (11.0.1.98) to see how it would look. It is not wrapping the texfields properly. The text is not shown vertically but where it should start wrapping, it totally cuts the text. This is not acceptable either. Please re-open this ticket.

  • zeroin

    11:45:07 PM GMT+00:00 Aug 17, 2011

    It would be really great if you could release updated v 10.3 with a fix. It affects a lot of applications. Thanks a lot!

  • Aris SY

    2:09:39 PM GMT+00:00 Aug 17, 2011

    This bug is severely impacting our live application at www.quickschools.com. We have hundreds of paying users who are suddenly seeing unreadable, vertically-growing text. This is making the application almost unusable.

  • LJCoffee

    10:02:18 AM GMT+00:00 Aug 17, 2011

    Although this issue is marked as closed and there seem to be some indicators that this problem has been addressed in a beta version of the player I would like to add that our company cannot afford to update years of (previously working) projects for multiple clients.
    This is affecting everything from simple promotional materials to complex CBTs.
    In some cases these courses require a considerable amount of time and effort to correct as the process involves much more than just exporting a new swf.

    I'm just hoping that a new player is released before client complaints start coming in.

    Thanks

  • ppgengler

    8:54:15 AM GMT+00:00 Aug 17, 2011

    Same symptoms, definitely affecting our users.

  • gk_0

    4:03:15 AM GMT+00:00 Aug 17, 2011

    Can you please consider backporting the patch for the bug as soon as possible?

    We are providing enterprise Flash-based e-learning applications and one of our products got unusable because of the bug, hurting our clients' trust on our products consequently.

    We managed to apply workaround for the particular instance of the bug, but still we are concerned about its impact on our other products.

    As in gus500's comments, the problem reproduces on Windows as well (IE/FF/Chrome) and it occurs with TextFields with non-dynamically attached ones. The impact of the bug seems to be more serious and your prompt act on this issue would be very much appreciated.

  • AbhiBrainNook

    5:17:36 PM GMT+00:00 Aug 16, 2011

    This is affecting our online game BrainNook (www.brainnook.com). Very frustrating because it happens only for people whose Chrome has auto-updated them to this Flash Player version, and there doesn't seem to be an easy way for them to roll back to an earlier version. It makes some screens in the game unreadable -- screens which have been stable and working for months.

  • lvrucci

    7:36:41 AM GMT+00:00 Aug 16, 2011

    We are also affected by this bug severely. We produce a good number of interactives (mostly from CS3) for some large customers that have worked fine up through 10.181 on IE6, IE8, IE9, Safari 5.0, Safari 5.1 and Firefox 5.0 - now they are all broken. The effect is that some of the text is unreadable (aside from looking crummy). The fields are configured as Dynamic Text, Multiline, HTML - font is Verdana and Use device fonts is specified. We are seeing this behavior on the initial field responded to by the user on each entry into the swf.

  • EricBanker

    11:41:13 AM GMT+00:00 Aug 15, 2011

    Our main playback environment for student lecture playback is exhibiting this issue causing main features of our player to be unusable. This is a major problem for us

  • fotoplayer

    2:31:36 AM GMT+00:00 Aug 13, 2011

    http://fotoplayer.com/v4/
    Check out the text in description window when you mouse over the slide. Pin the description window and view another slide, you won't see the issue as the window is not animated now.

  • gus500

    2:28:05 PM GMT+00:00 Aug 12, 2011

    I am seeing the same issue on Chrome and Firefox on Windows, Mac, and Linux.

  • kelvinraharja

    12:00:58 PM GMT+00:00 Aug 12, 2011

    I am also seeing this issue on Chrome, Firefox and Safari on the Mac running OSX 10.6.8. Dynamic textfields in SWF (published for Flash Player 8 and Flash Player 9) using device font are displaying the text vertically one character per line (except spaces).

Your session has expired! Click to login
Current form data will be preserved

Cancel