Adobe Flash Player 11.2  -  Bug 3097844

Created on Wednesday, January 25, 2012

Login for more options

Title

[Platform_Linux]Wrong colors at hardware accelerated rendering of stage video (11.2.202.183 beta)

Description

Problem Description: I get wrong colors at hardware accelerated rendering stage video. This means red colors are shown as blue and other way.

Steps to Reproduce: Install Ubuntu 11.10 (or similar distribution), current nvidia drivers and libvdpau1. Open Firefox and install Flash-aid addon to get newest Flash player beta and set some tweaks for hardware acceleration. Open youtube.com any play any video.

Actual Result: Colors of video are wrong. Red colors are shown as blue and other way.

Expected Result: Correct colors.

Any Workarounds: Disable stage video.

Test Configuration

ASRock E350M1 with ASUS EN210 (nVidia GeForce 210) GPU
Ubuntu 11.10 32-bit
Firefox 7.0.1
Flash Player 32-bit 11.2.202.183

App Language(s) ALL
OS Language(s) ALL
Platform(s) Linux
Browser(s) Firefox All

Notes (9)

  • belegdol

    10:44:45 AM GMT+00:00 Mar 1, 2012

    Still unfixed in RC aka 11.2.202.221.

  • swbfan

    1:35:08 AM GMT+00:00 Feb 6, 2012

    @belegdol: You're right. I didn't saw your request.

  • belegdol

    1:19:27 AM GMT+00:00 Feb 5, 2012

    Most likely a duplicate of 3077076. The problem with happen only with hardware rendering and software decoding. If both are done in either software or hardware, the problem will not occur.

  • belegdol

    1:19:06 AM GMT+00:00 Feb 5, 2012

    Most likely a duplicate of 3077076. The problem with happen only with hardware rendering and software decoding. If both are done in either software or hardware, the problem will not occur.

  • swbfan

    2:31:28 AM GMT+00:00 Feb 3, 2012

    I notice that this problem happens only if video decoding is done by software (EnableLinuxHWVideoDecode=0). If both rendering and decode enabled colors are correct but flash plugin crashes sometimes. I've sent crash report by flash plugin.

  • MrX1980

    12:51:13 AM GMT+00:00 Feb 3, 2012

    nVidia 295.17 beta driver for Linux:
    http://www.nvnews.net/vbulletin/showthread.php?p=2524716

    Firefox 10.0 and higher
    http://www.mozilla.org/en-US/firefox/all.html
    http://www.mozilla.org/en-US/firefox/channel/

    Ubuntu 12.04 Alpha 2
    http://cdimage.ubuntu.com/releases/12.04/alpha-2/

  • swbfan

    12:10:53 AM GMT+00:00 Feb 1, 2012

    Update: This bug still exists in Beta 5 (11.2.202.197)

  • swbfan

    3:56:01 AM GMT+00:00 Jan 30, 2012

    Thanks for confirming, Alex. Can you confirm this bug in previous beta versions too? I havn't found any download yet.

  • Alex1113

    1:45:13 PM GMT+00:00 Jan 25, 2012

    Same here, Ubuntu 11.10 64-bit, nvidia-current (280.13), nVidia GeForce GT 240 GPU.

Duplicate ID
Reported By swbfan

Status

State Closed
Status Withdrawn
Reason FeatureRemoved

Importance

Priority 0-Unknown
Frequency Unknown
Failure Type Video Card/Driver Limitation
Product Area Video

Build

Found In Build 11.2.202.160(beta)
Fixed In Build

Attachments (1)

Votes (0)

Your session has expired! Click to login
Current form data will be preserved

Cancel