Adobe Flash Player 11.2  -  Bug 3120888

Created on Wednesday, February 22, 2012

Login for more options

Title

[Platform_Windows]video playback swaps colors on linux chrome

Description

Problem Description:
When playing back a video on Linux under Chrome (version 19.0.1041.0), red and blue colors are swapped.

Steps to Reproduce:
Open Chrome and navigate to <http://www.youtube.com/watch?v=iBzVGWWpZAw>.

Actual Result:
Video is displayed incorrectly. Red and blue color channels are swapped.

Expected Result:
Video should be displayed correctly.

Any Workarounds:
Use Firefox.

Test Configuration

App Language(s) ALL
OS Language(s) ALL
Platform(s) Linux
Browser(s) Chrome All

Notes (12)

  • Zhe Wang

    9:41:56 PM GMT+00:00 Nov 5, 2012

    closed

  • bluefigtoast

    9:47:37 PM GMT+00:00 May 12, 2012

    A viable work around (not optimal):

    http://pkill-9.com/de-smurfing-youtube-or-people-youtube-blue/

    Wayno

  • almostkelvin

    4:48:22 PM GMT+00:00 Apr 1, 2012

    I have encountered the same bug (red and blue channels swapped) after upgrading to Flash 11.2.202.228 on Ubuntu 11.04 - I did not take note of the previous version (which was working correctly). This appears in both Firefox and Chrome. Turning hardware acceleration off shows the colors correctly (latest official Nvidia driver on Nvidia GeForce 330M card)

  • Udovdh

    10:12:40 AM GMT+00:00 Mar 31, 2012

    Fedora 16 x86_64., kernel.org 3.2.4, radeon git, mesa git. ATI gpu.
    11.2..whatever has the issue.
    11.1.102.55 works as it should.
    What was that about not supporting linux?
    Did you ever test this at all?

  • Diomas

    12:23:40 PM GMT+00:00 Mar 30, 2012

    I attached examples of how youtube looks now.

    It seems this bug affect sites that use StageVideo for playback so it's not only youtube problem.

    here is another site: http://blog.brightcove.com/en/2011/02/stage-video-brightcove-player

  • EaglesNestOne

    5:13:09 PM GMT+00:00 Mar 29, 2012

    Sorry for double post. Just updated to the latest nvidia driver. Still no change in behaviour.

  • EaglesNestOne

    4:59:38 PM GMT+00:00 Mar 29, 2012

    I've encountered this issue in 11.2 r202 after updating yesterday. Youtube videos have blue and red hues swapped. I'm currently using 32-bit Ubuntu 11.10 with the proprietary nvidia driver (290.10). My graphics card is the 9600GT. The issue only arises with hardware acceleration enabled. I ask that Adobe reconsiders opening this bug as it makes flash player completely unuseable for those who aren't aware of the hardware acceleration setting.

  • Jingbin Wang

    4:46:54 PM GMT+00:00 Feb 27, 2012

    thanks for your support Adobe Flash and report this issue. But we do not support Linux anymore post 11.2

  • swbfan

    4:41:47 AM GMT+00:00 Feb 27, 2012

    This is same bug reported at #3109467, #3097844 and #3077076. I think there's enough info and I really feel like I've been fooled.

  • Jingbin Wang

    9:16:01 PM GMT+00:00 Feb 26, 2012

    I tried on Linux Ubuntu Google Chrome 17.0.963.56 and I cannot reproduce this issue.
    Which Linux do you running on?
    And your GPU?

  • michaelpruett

    3:27:03 PM GMT+00:00 Feb 24, 2012

    Video playback is fine on my system with Flash 11.1.102.62. With Flash 11.2.202.197, red and blue color channels are swapped.

  • Jingbin Wang

    5:31:03 PM GMT+00:00 Feb 23, 2012

    Hi michaelpruett, are you encounter such issue on the Flash Player version 11.2.202.197? If you install a Flash Player version with 11.1.xxx, is the issue still there?

Duplicate ID
Reported By michaelpruett

Status

State Closed
Status Withdrawn
Reason FeatureRemoved

Importance

Priority 3-High
Frequency All users will encounter
Failure Type Incorrectly Functioning
Product Area Video

Build

Found In Build 11.2.202.197(beta)
Fixed In Build

Votes (1)

  • Diomas

    4:21:44 AM GMT+00:00 Mar 29, 2012

    This bug affects me. Colors are swapped on youtube.com videos since I update flashplayer from 11.1.102.63 to 11.2.202.228

    I use 64bit Ubuntu.

    Moreover, Opera browser starts freezing for about 10 seconds when I close tabs with these videos.

Your session has expired! Click to login
Current form data will be preserved

Cancel