ColdFusion 10.0  -  Bug 3315764

Created on Wednesday, August 22, 2012

Login for more options


CFFlush doesn't work.


Problem Description: CFFlush doesn't do anything.

Steps to Reproduce:
<CFFLUSH interval="10">
<CFSET StartTime = gettickcount()>
<CFLOOP FROM="1" TO="10" INDEX="this">
<CFOUTPUT><div>This is step ###This# - #NumberFormat(GetTickCount()-StartTime)#ms</div></CFOUTPUT>

Actual Result:

Nothing is outputted to the screen until all steps have completed and page request is done.

Expected Result:

To see a step outputted to the browser every 5 seconds

Any Workarounds:

None. Tag function is completely ignored.

Test Configuration

My Hardware and Environment details:

RECOMMENDATION: Write up a ColdFusion script that can be run to provide you with the exact information you required for this section or pre-populate this entire form with debugging information.

ColdFusion 10,282462 Developer
Windows 7 (6.1)
Adobe Driver Version 4.1 (Build 0001)
Java VM Version 20.4-b02

App Language(s) English
OS Language(s) English
Platform(s) Windows 7 SP1 64-bit
Browser(s) Firefox 4.0

Notes (3)

  • Anuj Nawani

    1:14:16 AM GMT+00:00 Sep 25, 2013

    This issue is fixed in Update 11 of CF 10.

  • James Moberg

    10:35:49 AM GMT+00:00 Aug 22, 2012

    In order for CFFlush to work, some manual text editing of config files is required... I missed this when installing and will now need to remind myself this whenever reinstalling CF10.
    To disable webserver buffer, change the is_buffer_enable to false in the cfroot\config\wsconfig\1\ file. Disable webserver buffer if you want cfflush to work over an IIS connector. If your application does not use cfflush, set it to true for increase in the performance.

    Please update all CF10 Tag documentation to indicate that the tags will only work if additional requirements are met. (This step wasn't required in past versions of ColdFusion.)

  • James Moberg

    10:14:05 AM GMT+00:00 Aug 22, 2012

    Tested in current versions of Windows Firefox, Chome, Internet Explorer, Opera and Safari to ensure that it wasn't some new browser behavior. Tested on Windows 7 w/IIS6.

Duplicate ID
Reported By James Moberg


State Closed
Status Fixed


Priority 4-Very High
Frequency All users will encounter
Failure Type Non Functioning
Product Area Web Container (Tomcat)


Found In Build Final
Fixed In Build

Attachments (0)

No Files Attached

Votes (1)

  • Jake Hand

    3:40:19 PM GMT+00:00 Jun 12, 2014

    Issue still occurs in CF 10 Update 13 with upgraded connector and "iis_buffer_enable= false" specified in

Your session has expired! Click to login
Current form data will be preserved